Main app is down.
Incident Report for Anymail Finder
Resolved
This incident has been resolved.
Posted Sep 16, 2018 - 20:36 UTC
Investigating
We are currently investigating this issue.
Posted Sep 16, 2018 - 20:08 UTC
This incident affected: Web app.