Inability to run searches from homepage when logged out
Incident Report for Anymail Finder
Resolved
This incident has been resolved.
Posted 11 months ago. Nov 14, 2016 - 13:13 UTC
Identified
We have identified the issue and are deploying a fix
Posted 11 months ago. Nov 14, 2016 - 13:07 UTC
Investigating
We are investigating reports that logged out users might be unable to run searches from the homepage.
Posted 11 months ago. Nov 14, 2016 - 12:58 UTC