Web app unavailable
Incident Report for Anymail Finder
Resolved
The issue has now been resolved by AWS
Posted Apr 18, 2018 - 11:20 UTC
Identified
Due to an issue with our data server the web app is currently unavailable. We are currently working with our hosting provider to get this solved ASAP
Posted Apr 18, 2018 - 11:11 UTC