Slow search + partial website downtime
Incident Report for Anymail Finder
Resolved
This incident has been resolved.
Posted 10 months ago. Aug 09, 2016 - 22:23 UTC
Identified
The website might be offline in some regions, and searches might be running slower than usual. We are fixing it right now.
Posted 10 months ago. Aug 09, 2016 - 19:16 UTC