A problem with our main database is affecting our API and web app
Incident Report for Anymail Finder
Resolved
This incident has been resolved.
Posted 2 months ago. Nov 18, 2016 - 11:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Nov 18, 2016 - 11:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 2 months ago. Nov 18, 2016 - 11:19 UTC