Slow searches
Incident Report for Anymail Finder
Resolved
This incident has been resolved.
Posted over 1 year ago. Nov 29, 2016 - 17:17 UTC
Investigating
We're currently investigating a problem with the search
Posted over 1 year ago. Nov 29, 2016 - 16:40 UTC