Degraded performance of website and Api
Incident Report for Anymail Finder
Resolved
It's solved
Posted about 1 year ago. Sep 22, 2016 - 21:31 UTC
Monitoring
We have identified and solved the issue and will continue monitoring for the next few minutes
Posted about 1 year ago. Sep 22, 2016 - 21:08 UTC
Investigating
We are investigating the issue
Posted about 1 year ago. Sep 22, 2016 - 20:50 UTC