Datatabase instance upgrade needed to deal with backlog.
Incident Report for Anymail Finder
Resolved
This incident has been resolved.
Posted 8 months ago. Jan 12, 2018 - 11:25 UTC
Investigating
This is a major outage and searches will not run on the main app until it's cleared.
Posted 8 months ago. Jan 12, 2018 - 11:00 UTC