Slow single searches
Incident Report for Anymail Finder
Resolved
This incident has been resolved.
Posted Jan 31, 2018 - 15:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 31, 2018 - 11:39 UTC
Identified
We have noticed worse than usual results on single searches and are resolving the situation.
Posted Jan 31, 2018 - 11:13 UTC