Degraded chrome extension performance
Incident Report for Anymail Finder
Resolved
This incident has been resolved.
Posted 8 months ago. Oct 27, 2016 - 14:33 UTC
Monitoring
The issue should now be resolved, we are monitoring the situation.
Posted 8 months ago. Oct 27, 2016 - 09:52 UTC
Update
We're waiting for a fix to be deployed to the Chrome web store.
Posted 8 months ago. Oct 27, 2016 - 09:39 UTC
Identified
We've identified an issue with the Chrome extension that might affect performance and will be resolved shortly.
Posted 8 months ago. Oct 27, 2016 - 09:20 UTC