Job title update / fix taking place. Job titles will be down for the day.
Incident Report for Anymail Finder
Resolved
This incident has been resolved.
Posted Feb 20, 2021 - 13:40 UTC
Update
We are continuing to investigate this issue.
Posted Feb 16, 2021 - 12:01 UTC
Investigating
We are currently investigating this issue.
Posted Feb 16, 2021 - 11:59 UTC
This incident affected: Web app and API.