Download file issues. Some files are coming back without results.
Incident Report for Anymail Finder
Resolved
This incident has been resolved.
Posted Feb 27, 2021 - 15:56 UTC
Investigating
We are currently investigating this issue.
Posted Feb 26, 2021 - 14:32 UTC
This incident affected: Web app.