Job title search is not working at present.
Incident Report for Anymail Finder
Resolved
This incident has been resolved.
Posted Feb 15, 2021 - 13:11 UTC
Investigating
We are currently investigating this issue.
Posted Feb 14, 2021 - 23:17 UTC
This incident affected: Web app and API.