Investigating issue with Job title and company name search
Incident Report for Anymail Finder
Resolved
This incident has been resolved.
Posted Jan 27, 2021 - 17:44 UTC
Update
We are continuing to investigate this issue.
Posted Jan 27, 2021 - 13:16 UTC
Investigating
We are currently investigating this issue.
Posted Jan 27, 2021 - 13:16 UTC
This incident affected: Web app and API.