Intermittent downtime today during API upgrade and rollout. Expect temporary downtime periods of a few minutes at a time.
Incident Report for Anymail Finder
Resolved
This incident has been resolved.
Posted Mar 05, 2021 - 17:48 UTC
Investigating
We are currently investigating this issue.
Posted Mar 05, 2021 - 14:13 UTC
This incident affected: Web app.